{"id":"CVE-2026-76466","published":"2026-10-21T17:19:06.813","lastModified":"2026-10-22T23:19:07.397","description":"A vulnerability in the database service feature of Cisco Expressway Series could allow an unauthenticated, remote attacker with network access to a Cisco Expressway device to execute arbitrary operating system commands as&nbsp;root.\r\n\r\nThis vulnerability is due to the use of persistent cookies. Additionally, there is insufficient validation of client certificates when the TLS Verify Mode is set to Enabled for clustering, which means that client certificates are not validated. An attacker with possession of the cookies could exploit this vulnerability by connecting to the database service and invoking specific remote procedure call (RPC) commands. A successful exploit could allow the attacker to execute arbitrary commands as root on the underlying operating system of an affected device.\r\nNote: Cisco Expressway Series refers to Cisco Expressway Core (Expressway-C) devices and Cisco Expressway Edge (Expressway-E) devices.","cvssScore":9.8,"cvssSeverity":"CRITICAL","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cwes":["CWE-798"],"vendors":[],"products":[],"references":[{"url":"https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-vcs-static-cred-hr7EWZ8t","tags":[]}],"exploitRefs":[],"hasPoc":false,"ai":{"summary":"A critical authentication bypass in Cisco Expressway's database service allows unauthenticated remote attackers to execute arbitrary commands as root due to weak cookie-based persistence and missing client certificate validation during clustering.","exploitability":"Exploitation requires network access and possession of valid persistent cookies; no user interaction or prior authentication is needed.","blast_radius":"Successful exploitation grants full system compromise (root-level RCE) on affected Expressway-C and Expressway-E devices, enabling full data exfiltration, lateral movement, or service disruption.","remediation":"Upgrade to Cisco Expressway version 2.590 or later, as this is the fixed version that addresses the vulnerability in the database service.","detection":"No reliable host or network indicator is derivable from the published description.","tags":["rce","auth-bypass","cookie-abuse","tls-misconfig","ics","cisco"],"model":"garnet-coder","analyzedAt":"2026-10-24T08:55:31.302Z"}}