{"id":"CVE-2026-15230","published":"2026-08-05T07:16:35.010","lastModified":"2026-08-05T16:16:50.447","description":"The YayPricing  WordPress plugin before 3.5.7 does not perform capability checks on several of its REST API routes, relying only on a shared nonce, allowing any authenticated user such as a subscriber to overwrite the store's pricing configuration and to disclose private coupon codes.","cvssScore":8.1,"cvssSeverity":"HIGH","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","cwes":["CWE-284"],"vendors":[],"products":[],"references":[{"url":"https://wpscan.com/vulnerability/c2346f90-130c-45da-92ca-31acaa2f4605/","tags":[]}],"exploitRefs":[],"hasPoc":false,"ai":{"summary":"The flaw in YayPricing WordPress plugin allows any authenticated user to overwrite pricing configurations and disclose private coupon codes due to missing capability checks.","exploitability":"Exploitation is relatively easy as it requires only an authenticated user, such as a subscriber, to perform actions on REST API routes.","blast_radius":"If exploited, the impact could be significant, as it allows unauthorized modification of pricing and disclosure of sensitive coupon codes, affecting the store's operations and customer trust.","remediation":"Upgrade to YayPricing version 3.5.7 or later.","detection":"No reliable host or network indicator is derivable from the published description.","tags":["auth-bypass","web","config-overwrite","coupon-disclosure"],"model":"qwen2.5:7b-instruct","analyzedAt":"2026-10-05T08:45:41.551Z"}}