{"id":"CVE-2026-121652","published":"2026-11-03T19:18:05.363","lastModified":"2026-11-03T20:18:13.460","description":"Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl.\n\n\n\nTo remediate this issue, users should upgrade to 4.0.3 or later.","cvssScore":5.4,"cvssSeverity":"MEDIUM","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","cwes":["CWE-79"],"vendors":[],"products":[],"references":[{"url":"https://aws.amazon.com/security/security-bulletins/2026-167-aws/","tags":[]},{"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3","tags":[]},{"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9","tags":[]}],"exploitRefs":[{"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3","tags":[]},{"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9","tags":[]}],"hasPoc":true,"ai":null}