{"id":"CVE-2026-116852","published":"2026-10-30T19:18:15.020","lastModified":"2026-10-30T23:17:09.227","description":"Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.","cvssScore":9.1,"cvssSeverity":"CRITICAL","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","cwes":["CWE-94"],"vendors":[],"products":[],"references":[{"url":"https://patchstack.com/database/wordpress/plugin/widget-options/vulnerability/wordpress-widget-options-plugin-4-2-5-remote-code-execution-rce-vulnerability?_s_id=cve","tags":[]}],"exploitRefs":[],"hasPoc":false,"ai":{"summary":"A remote code execution (RCE) vulnerability exists in Widget Options plugin versions <= 4.2.5 due to improper input validation (CWE-94), allowing authenticated authors to inject and execute arbitrary PHP code.","exploitability":"Exploitation requires high-privilege access (author role or higher) with no user interaction, making it difficult for unauthenticated attackers but serious for compromised or insider threats.","blast_radius":"Successful exploitation could lead to full system compromise including data theft, backdoor installation, and lateral movement within the WordPress environment.","remediation":"Upgrade to Widget Options version 4.2.6 or later, which contains the official patch for this vulnerability.","detection":"Look for suspicious PHP code execution in web server logs (e.g., POST requests to /wp-admin/admin-ajax.php with base64-encoded payloads or eval() calls) and unexpected file creation/modification under wp-content/uploads/ by author-level users.","tags":["rce","wordpress","plugin","php-injection","auth-bypass"],"model":"garnet-coder","analyzedAt":"2026-10-31T08:49:56.240Z"}}