{"id":"CVE-2026-112712","published":"2026-10-20T21:17:17.910","lastModified":"2026-10-22T15:25:17.817","description":"@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.","cvssScore":9.1,"cvssSeverity":"CRITICAL","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","cwes":["CWE-436"],"vendors":[],"products":[],"references":[{"url":"https://cna.openjsf.org/security-advisories.html","tags":[]},{"url":"https://github.com/fastify/middie/security/advisories/GHSA-5p92-8765-9fv8","tags":[]}],"exploitRefs":[{"url":"https://github.com/fastify/middie/security/advisories/GHSA-5p92-8765-9fv8","tags":[]}],"hasPoc":true,"ai":{"summary":"A path construction bug in @fastify/middie versions 9.0.0–9.3.5 caused path-scoped middleware (e.g., auth, rate limiting) to be silently skipped when the scope prefix ended with a slash or when using array/non-leading-slash mount paths, allowing unauthenticated requests to bypass intended protections.","exploitability":"Trivial to exploit remotely without authentication or user interaction; requires only crafting a request to a vulnerable path pattern.","blast_radius":"Any application using affected versions of @fastify/middie with path-scoped middleware is at risk of complete authentication/authorization bypass, potentially exposing sensitive endpoints and data.","remediation":"Upgrade to @fastify/middie version 9.3.6 or later immediately.","detection":"No reliable host or network indicator is derivable from the published description.","tags":["auth-bypass","middleware","nodejs","fastify","path-traversal"],"model":"garnet-coder","analyzedAt":"2026-10-25T08:51:06.591Z"}}