{"id":"CVE-2026-112362","published":"2026-10-27T12:17:04.970","lastModified":"2026-10-27T15:03:41.023","description":"@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.","cvssScore":9.1,"cvssSeverity":"CRITICAL","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","cwes":["CWE-436"],"vendors":[],"products":[],"references":[{"url":"https://cna.openjsf.org/security-advisories.html","tags":[]},{"url":"https://github.com/fastify/fastify-express/security/advisories/GHSA-6h42-57hq-9746","tags":[]}],"exploitRefs":[{"url":"https://github.com/fastify/fastify-express/security/advisories/GHSA-6h42-57hq-9746","tags":[]}],"hasPoc":true,"ai":{"summary":"A path confusion flaw in @fastify/express (versions 4.0.5–4.0.8) allows unauthenticated attackers to bypass scoped middleware (e.g., auth or rate limiting) when Fastify’s ignoreDuplicateSlashes option is enabled, by sending a request with an absolute-form URI that collapses duplicate slashes after the scheme, causing Fastify to route to the protected path while Express skips its middleware.","exploitability":"Exploitation requires only the non-default ignoreDuplicateSlashes option to be enabled; no authentication or special privileges are needed.","blast_radius":"An attacker could bypass critical security controls on admin or sensitive routes, leading to unauthorized access or privilege escalation depending on the affected application’s routing structure.","remediation":"Upgrade to @fastify/express version 4.0.9 or later; alternatively, disable ignoreDuplicateSlashes (its default) or enforce authentication in a Fastify preHandler hook.","detection":"No reliable host or network indicator is derivable from the published description.","tags":["auth-bypass","path-confusion","middleware-skipping","fastify","express"],"model":"garnet-coder","analyzedAt":"2026-10-28T10:03:46.642Z"}}