{"id":"CVE-2026-111821","published":"2026-11-04T10:17:25.363","lastModified":"2026-11-04T14:10:09.713","description":"Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB.\n\n\n\nA user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable. \n\n\n\nThis issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12.\n\n\n\nUsers are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.","cvssScore":null,"cvssSeverity":null,"cvssVector":null,"cwes":["CWE-20"],"vendors":[],"products":[],"references":[{"url":"https://lists.apache.org/thread/p8gxq66lmztkrls74wkz3xh9chqd0pwl","tags":[]},{"url":"http://www.openwall.com/lists/oss-security/2026/11/03/19","tags":[]}],"exploitRefs":[],"hasPoc":false,"ai":null}