{"id":"CVE-2026-107329","published":"2026-10-29T16:17:50.633","lastModified":"2026-10-30T04:18:03.613","description":"IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote authenticated attacker to execute arbitrary code due to improper control of code generation.","cvssScore":9.9,"cvssSeverity":"CRITICAL","cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","cwes":["CWE-94"],"vendors":[],"products":[],"references":[{"url":"https://www.ibm.com/support/pages/node/7293016","tags":[]}],"exploitRefs":[],"hasPoc":false,"ai":{"summary":"IBM Langflow OSS versions 1.0.0 through 1.12.4 contain a code injection flaw (CWE-94) where an authenticated attacker can execute arbitrary code due to improper control of code generation, leading to full system compromise.","exploitability":"Exploitation requires valid authentication and low privilege access, with no user interaction needed; difficulty is moderate due to the direct code execution path.","blast_radius":"Successful exploitation allows full compromise of confidentiality, integrity, and availability of the affected system and potentially downstream services if Langflow integrates with other components.","remediation":"Upgrade to IBM Langflow OSS version 1.12.5 or later, as this is the first fixed version addressing the code injection vulnerability.","detection":"No reliable host or network indicator is derivable from the published description.","tags":["rce","code-injection","auth-bypass","web","oss"],"model":"garnet-coder","analyzedAt":"2026-10-30T09:11:43.742Z"}}