{"id":"CVE-2026-101296","published":"2026-10-20T14:16:54.767","lastModified":"2026-10-21T04:16:58.097","description":"A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password.\n\n\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122.\n\n\n\nThe following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.\n\n\n\nUsers are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.","cvssScore":null,"cvssSeverity":null,"cvssVector":null,"cwes":["CWE-304"],"vendors":[],"products":[],"references":[{"url":"https://lists.apache.org/thread.html/bl52b9go9ckoov8x4v3dt6rkm573cygd","tags":[]},{"url":"http://www.openwall.com/lists/oss-security/2026/10/20/26","tags":[]}],"exploitRefs":[],"hasPoc":false,"ai":null}